Etheruem: Pyethereum Error

0 votes

After installing pyethereum I get the following error asking to upgrade my setuptools. I have upgraded setuptools but it seems my system can't still recognize it.

Here is the error I get:

error: Setup script exited with Your setuptools version (1.1.6) is too old to
correctly install this package. Please upgrade to a newer version (>= 3.3).
Sep 28, 2018 in Blockchain by slayer
• 29,170 points
19 views

1 answer to this question.

0 votes

Try running this:

sudo easy_install -U setuptools

In my case, this took me to setuptools version 25.4.0 for Python version 2.7 on my Mac, which I verified by running this:

sudo easy_install --version

setuptools 25.4.0 from /Library/Python/2.7/site-packages/setuptools-25.4.0-py2.7.egg (Python 2.7)
answered Sep 28, 2018 by digger
• 26,550 points

Related Questions In Blockchain

0 votes
1 answer

How can I write complex decentralized applications on Etheruem?

Well, if you want to create a ...READ MORE

answered Apr 18, 2018 in Blockchain by Perry
• 17,020 points
34 views
+1 vote
1 answer

Error while deploying chaincode in IBM Blockchain. Please help.

Try stripping out the 'tree/master' portion of ...READ MORE

answered Apr 26, 2018 in Blockchain by Christine
• 15,790 points
98 views
0 votes
1 answer

Unknown MSP DEFAULT error query chaincode

./byfn.sh -m up After running the above command, ...READ MORE

answered Jun 8, 2018 in Blockchain by Christine
• 15,790 points
44 views
0 votes
1 answer

Truffle tests not running after truffle init

This was a bug. They've fixed it. ...READ MORE

answered Sep 11, 2018 in Blockchain by Christine
• 15,790 points
170 views
0 votes
1 answer
0 votes
1 answer

Protocols used in a distributed/dlt system for the nodes to establish communication

yes all are over TCP/IP connections secured by TLS encryption in hashgraph architecture-hashgraph, ...READ MORE

answered Aug 6, 2018 in Blockchain by ariaholic
• 7,340 points
91 views
0 votes
1 answer