Issue in running Corda as a service

0 votes

I am trying to run corda as a Windows service. I followed all the steps in documentation. As per the steps the node configuration and corda.jar is invoked by a NSSM service manager. Nowhere it is mentioned to start the controller node. I assume a controller node should be running as a prerequisite. In node.conf file

networkMapService {
    address="networkmap.foo.bar.com:10002"
    legalName="O=FooBar NetworkMap, L=Dublin, C=IE" }

networkMapService is pointing to some address. So should I deploy and run the Cordapp before I run the nssm.bat file ? However I when I opened the log file I see the below error though I have the certificates in place. Exception during node startup java.lang.IllegalArgumentException: Identity certificate not found. Please either copy your existing identity key and certificate from another node, or if you don't have one yet, fill out the config file and run corda.jar --initial-registration. I am clueless. Please someone help me understand this process.

Aug 27, 2018 in Blockchain by ariaholic
• 7,320 points
65 views

1 answer to this question.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
0 votes

There are a few issues with the docs there:

  1. When deploying a node, we are assuming that you are going to provision real certificates to the node. This step is only documented in the Linux instructions (See step 11: 11. Provision the required certificates to your node. Contact the network permissioning service or see Network Permissioning). You can create your own certificates by following the instructions here (https://docs.corda.net/permissioning.html)

  2. We are assuming that there is already a node operating a network map service at the address listed in node.conf

I'll raise a PR to fix these issues.

If you are interested in running nodes across different machines in dev mode instead, see https://docs.corda.net/tutorial-cordapp.html#running-nodes-across-machines.

answered Aug 27, 2018 by Johnathon
• 9,030 points

Related Questions In Blockchain

0 votes
1 answer
0 votes
1 answer
0 votes
1 answer

IPFS transaction cost as a decentralized service

IPFS itself does not have transaction cost, ...READ MORE

answered Aug 3, 2018 in Blockchain by Perry
• 16,450 points
80 views
0 votes
1 answer

Truffle tests not running after truffle init

This was a bug. They've fixed it. ...READ MORE

answered Sep 11, 2018 in Blockchain by Christine
• 15,790 points
60 views
0 votes
1 answer
+1 vote
1 answer

How Blockchain work in a mobile app?

At present there is no provision to ...READ MORE

answered Apr 10, 2018 in Blockchain by Johnathon
• 9,030 points
45 views

© 2018 Brain4ce Education Solutions Pvt. Ltd. All rights Reserved.
"PMP®","PMI®", "PMI-ACP®" and "PMBOK®" are registered marks of the Project Management Institute, Inc. MongoDB®, Mongo and the leaf logo are the registered trademarks of MongoDB, Inc.