WAMP error Forbidden You don t have permission to access phpmyadmin on this server

0 votes

I am new to WAMP and have noticed that the setup went well and localhost seems to work, but when I try to access phpMyAdmin I get this ERROR:

Forbidden

You don't have permission to access /phpmyadmin/ on this server.

Why do I get this permission access error by using phpMyAdmin? I am using Windows 7.

Feb 23 in Others by Rahul
• 9,240 points
3,364 views

1 answer to this question.

0 votes

Change the file content of c:\wamp\alias\phpmyadmin.conf to the following.

You should remember to set the Allow Directive to allow it from your local machine for security purposes. The directive Allow from all is insecure and should be limited to your local machine.

<Directory "c:/wamp/apps/phpmyadmin3.4.5/"> 
      Options Indexes FollowSymLinks MultiViews 
      AllowOverride all 
                  Order Deny,Allow 
                  Allow from all 
</Directory>

Here my WAMP installation is in the c:\wamp folder. Change it according to your installation.

Previously, it was like this:
 

<Directory "c:/wamp/apps/phpmyadmin3.4.5/"> 
        Options Indexes FollowSymLinks MultiViews 
        AllowOverride all 
                  Order Deny,Allow 
              Deny from all 
              Allow from 127.0.0.1 
</Directory>

Modern versions of Apache 2.2 and up will look for a IPv6 loopback instead of a IPv4 loopback which is your localhost.


The real problem is that wamp is binding to an IPv6 address. The fix: just add Allow from ::1 - Tiberiu-Ionuț Stan
 

<Directory "c:/wamp22/apps/phpmyadmin3.5.1/"> 
      Options Indexes FollowSymLinks MultiViews 
      AllowOverride all 
            Order Deny,Allow 
      Deny from all 
      Allow from localhost 127.0.0.1 ::1 
</Directory>

This will allow only the local machine to access local apps for Apache.

Restart your Apache server after making these changes. 

answered Feb 23 by Aditya
• 7,660 points

Related Questions In Others

0 votes
1 answer

HTTP Error 403.14 - Forbidden - The Web server is configured to not list the contents of this directory

Try keeping this into your web config ...READ MORE

answered Feb 11 in Others by Rahul
• 9,240 points
3,061 views
0 votes
1 answer

ERROR: You need elevated Administrator privileges in order to run this script.

Hi@akhtar, I guess you are trying to run ...READ MORE

answered Sep 8, 2020 in Others by MD
• 95,360 points
639 views
–1 vote
0 answers
0 votes
1 answer
0 votes
1 answer

Chmod 777 to a folder and all contents

To help you with your doubt, if ...READ MORE

answered Feb 9 in Linux Administration by Rahul
• 9,240 points
1,477 views
0 votes
1 answer
0 votes
1 answer
webinar REGISTER FOR FREE WEBINAR X
REGISTER NOW
webinar_success Thank you for registering Join Edureka Meetup community for 100+ Free Webinars each month JOIN MEETUP GROUP