Error while running docker run command

+1 vote

I’ve been trying to run the jenkinsci/blueocean image as a container in docker using the following docker run command

But I’m ending up with the following error-

docker: Error response from daemon: repository jenkinsci/blueecean not found: does not exist or no pull access.

Jul 26, 2018 in Docker by Hannah
• 18,570 points

1 answer to this question.

+1 vote

This error occurs when your port is already being used up. Right now I’m assuming you have Jenkins running on your 8080 port and hence docker is not being able to pull.

Exit Jenkins by typing


And then try running the same command.

Use sudo before the command.

It worked for me, it should work for you as well.

answered Jul 26, 2018 by Kalgi
• 52,360 points
Hi :)
I am having similar issue and I am a newbie to Jenkins also.
Jenkins is already is installed n the server with many jobs/projects I have logged into but I would like to know if try above method to run the jenkinsci/blueocean image(exit localhost:8080), the existing Jenkins config would disappear.
Please let me know if there is any better approach?
Thanks in advance.
If you already have a Jenkins instance running you can use the Blue Ocean plugin to get all of its features. Your existing pipeline projects will continue to work as usual.
Can't we change the port number here?
Existing jenkins configuration will not disappear, they'll remain just the way but where you're configuring the job make sure you apply and save. And then you can run the jenkins/blueocean image the normal way.
@Bolder, When we install docker, by default it's set to port 8080. We basically have to exit whatever is running on port 8080. In my case I had jenkins running on 8080.

Related Questions In Docker

0 votes
1 answer

Error while trying to run an image - Docker

This error means that the container tries ...READ MORE

answered Aug 22, 2018 in Docker by Nilesh
• 7,050 points
0 votes
1 answer

Error saying "E: This command can only be used by root." while installing docker

Try executing the following command: sudo su and ...READ MORE

answered Aug 6, 2019 in Docker by Ahmad
0 votes
1 answer
+2 votes
1 answer
+2 votes
1 answer

Deploy Docker Containers from Docker Cloud

To solve this problem, I followed advice ...READ MORE

answered Sep 3, 2018 in AWS by Priyaj
• 58,090 points
0 votes
1 answer

Error while executing docker run command

This error occurs when your port is ...READ MORE

answered Jul 26, 2018 in Docker by Kalgi
• 52,360 points
+14 votes
19 answers

How can I run a ‘docker exec’ command inside a docker container?

you can run any command in a ...READ MORE

answered Dec 10, 2018 in Docker by Pramiti
webinar_success Thank you for registering Join Edureka Meetup community for 100+ Free Webinars each month JOIN MEETUP GROUP