How do I fix this error? docker run --- name “xyz” is already in use by container

0 votes

Executing docker with the following command always lands an error:

$ docker run \

     -d --name registry-v1 \

     -e SETTINGS_FLAVOR=local \

     -e STORAGE_PATH=/registry \

     -e SEARCH_BACKEND=sqlalchemy \

     -e LOGLEVEL=DEBUG \

     -p 5000:5000 \

     registry:0.9.1
Error response from daemon: Conflict. The name "registry-v1" is already in use by container g6e5398a82a0. You have to delete (or rename) that container to be able to reuse that name.

How to get rid of this error?

Jul 16, 2018 in Docker by Tyrion anex
• 8,280 points
260 views

1 answer to this question.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
0 votes
This is due to a confusion. There are two commands that are relevant here:

docker run - Runs a command in a new container

docker start - Starts a stopped container
answered Jul 16, 2018 by Sophie may
• 9,050 points

Related Questions In Docker

0 votes
1 answer

How do I run a docker image as a container?

You can run an image depends on whether you ...READ MORE

answered Sep 7, 2018 in Docker by Damon Salvatore
• 5,270 points
30 views
0 votes
1 answer

How do I scale in Docker Swarm Mode W/Terraform Digital Ocean Load Balancing

The solution you could build for Digital ...READ MORE

answered Jun 19, 2018 in Docker by shubham
• 6,500 points
136 views
+2 votes
11 answers
0 votes
1 answer
0 votes
1 answer

Deploy Docker Containers from Docker Cloud

To solve this problem, I followed advice ...READ MORE

answered Sep 3, 2018 in AWS by Priyaj
• 56,120 points
59 views
0 votes
2 answers
0 votes
1 answer

How do I run Windows 7 in docker?

Well, I’m not so sure of this, ...READ MORE

answered Nov 8, 2018 in Docker by Sophie may
• 9,050 points
46 views

© 2018 Brain4ce Education Solutions Pvt. Ltd. All rights Reserved.
"PMP®","PMI®", "PMI-ACP®" and "PMBOK®" are registered marks of the Project Management Institute, Inc. MongoDB®, Mongo and the leaf logo are the registered trademarks of MongoDB, Inc.