What are the current and correct repositories for ParrotSec OS, and how do i set them so that I can upgrade to the newest ParrotSec OS in VMware Workstation15?

+1 vote
I'm running ParrotSec OS 4.5 in VMware Workstation 15 and I can't really get much going. I have tried about a dozen ways to setup the VM with the correct network settings so that I could get online with it but I am having some troubles there, which is preventing me from upgrading to the newest update, 4.9, I think. Please help so that I can get the repository issue handled here.
May 3 in Cyber Security & Ethical Hacking by Eric
• 140 points
61 views

Hey, @Eric,

You can follow this to set up the correct repository:

To configure and custom setup: The APT package manager uses /etc/apt/sources.list and any .list file found in the /etc/apt/sources.list.d/ directory

NOTE:

/etc/apt/sources.list is EMPTY and the default APT configuration is located at /etc/apt/sources.list.d/parrot.list.

The Content of /etc/apt/sources.list.d/parrot.list:

deb https://deb.parrot.sh/parrot/ rolling main contrib non-free #deb-src https://deb.parrot.sh/parrot/ rolling main contrib non-free deb https://deb.parrot.sh/parrot/ rolling-security main contrib non-free #deb-src https://deb.parrot.sh/parrot/ rolling-security main contrib non-free

I suggest you use rsync.parrot.sh for automatic and failproof setups, which handle several domains for repository syncing services

1 answer to this question.

0 votes
Being a rolling release, version 4.5 is no longer supported. Any further attempts to upgrade it, even with newer repo sources.list, might break that system. Download the latest version of the OS - either ISO or OVA - and reinstall it.
answered May 4 by Carter O'Niell

Related Questions In Cyber Security & Ethical Hacking

0 votes
1 answer
0 votes
1 answer
0 votes
1 answer
0 votes
1 answer
0 votes
1 answer
0 votes
1 answer