SteemJS not working in Firefox/IE

0 votes

I have a problem with connecting Steem using SteemJs https://github.com/adcpm/steem

Problem appears only on firefox browser, but Chrome Works correctly.

Our app is coded in Yii2 and JavaScript, which works fully in front-end

<script src="//cdn.steemjs.com/lib/latest/steem.min.js"></script>
<script>
          steem.broadcast.comment('5K8eZVEAMkfejyHxeQJ9R4wvrXowwz7kcxcTVwFGpeGq1x2iKRb', 
             '', 
             ‘test', 
             'sci', 
             'this-is-a-test-article-2', 
             'this is a test article2', 
             'test', 
             '', 
            function(err, result) {
                console.log(err, result);
        });

Problem in the following process: When running request to blockchain , it return null in Chrome. Null is mean ok! so everything is fine

But when running on Firefox error occures:

Error: 3030000 tx_missing_posting_auth: missing required posting authority
Missing Posting Authority sci

…..
 {"ops":[["comment",    {"parent_author":"","parent_permlink":"test","author":"sci","permlink":"this-is-a-test-article-2","title":"this is a test article2","body":"test","json_metadata":"\"\""}]],"sigs":    ["STM7x7kJhdKzu7gie8gPg5uUDNmLjbcXx7ek2H8UtKxH8qub3V2ut"]}
th_a  transaction.cpp:172 verify_authority

Sigs here - is always different,but should be same and must be equal to public key from private: GLS8MfcHZyYioPBsmoYp8AZf4mbwZdsarunFRvuWUySqb3nwPeRwb.

In chrome it is working right key.

This is browser-compatibility problem, or browser feature problem Please help identify a problem, and possible we can patch it or overcome in another way.

Sep 14, 2018 in Blockchain by slayer
• 29,040 points
18 views

1 answer to this question.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
0 votes
npm install adcpm/steem#dev

Just build it from develop branch and problem will solved. In lib folder you can find steem.min.js.

answered Sep 14, 2018 by digger
• 27,620 points

Related Questions In Blockchain

0 votes
1 answer

setEtherbase() not working in geth

setEtherbase() is not a method of the personal ...READ MORE

answered Jan 16 in Blockchain by Omkar
• 65,850 points
16 views
0 votes
1 answer

Why am I not getting 100 ethers in my metamask account?

Sorry that you're having this problem. To ...READ MORE

answered Jun 14, 2018 in Blockchain by Christine
• 15,790 points
76 views
0 votes
1 answer

Account not listed in the Deploy Contract screen?

You need to get an initial allocated ...READ MORE

answered Jun 4, 2018 in Blockchain by Perry
• 16,450 points
9 views
0 votes
1 answer

Geth 'sendTransaction' not working

When transactions are put in a loop, ...READ MORE

answered Jul 3, 2018 in Blockchain by Omkar
• 65,850 points
36 views
0 votes
1 answer

Protocols used in a distributed/dlt system for the nodes to establish communication

yes all are over TCP/IP connections secured by TLS encryption in hashgraph architecture-hashgraph, ...READ MORE

answered Aug 6, 2018 in Blockchain by ariaholic
• 7,320 points
43 views
0 votes
1 answer

Truffle tests not running after truffle init

This was a bug. They've fixed it. ...READ MORE

answered Sep 11, 2018 in Blockchain by Christine
• 15,790 points
65 views
0 votes
1 answer

© 2018 Brain4ce Education Solutions Pvt. Ltd. All rights Reserved.
"PMP®","PMI®", "PMI-ACP®" and "PMBOK®" are registered marks of the Project Management Institute, Inc. MongoDB®, Mongo and the leaf logo are the registered trademarks of MongoDB, Inc.