What version of npm works with nodejs 0 10

0 votes

I'm attempting to install CartoDD according to the instructions. http://cartodb.readthedocs.org/en/latest/install.html

To work, you'll need nodejs 0.10. This is exactly what the instructions say:

sudo add-apt-repository ppa:cartodb/nodejs-010 && sudo apt-get update
sudo apt-get install nodejs 
sudo apt-get install npm

It install nodejs 0.10 OK, but it gives this error message when trying to install npm:

~$ sudo apt-get install npm
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 npm : Depends: nodejs but it is not going to be installed
       Depends: nodejs-dev
       Depends: node-request but it is not going to be installed
       Depends: node-mkdirp but it is not going to be installed
       Depends: node-minimatch but it is not going to be installed
       Depends: node-semver but it is not going to be installed
       Depends: node-ini but it is not going to be installed
       Depends: node-graceful-fs but it is not going to be installed
       Depends: node-abbrev but it is not going to be installed
       Depends: node-nopt but it is not going to be installed
       Depends: node-fstream but it is not going to be installed
       Depends: node-rimraf but it is not going to be installed
       Depends: node-tar but it is not going to be installed
       Depends: node-which but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

There is an npm installation that I think was installed at the same time as nodejs:

~$ npm -v

Is this the right npm version for NodeJS 0.10? I'm not sure if it was there already. This apt-cache output is really more worrying since it says npm is not installed, but I have just executed it:

~$ apt-cache policy npm
  Installed: (none)
  Candidate: 1.1.4~dfsg-1
  Version table:
     1.1.4~dfsg-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages

There's something else that makes me think there is something wrong with this installation. npm install works for the most part, but later on in the installation, when trying to install the MAPS API, I get this errors:

Package cairo was not found in the pkg-config search path.
Perhaps you should add the directory containing `cairo.pc'
to the PKG_CONFIG_PATH environment variable
No package 'cairo' found
gyp: Call to './util/has_cairo_freetype.sh' returned exit status 0.
gyp ERR! configure error 
gyp ERR! stack Error: `gyp` failed with exit code: 1
gyp ERR! stack     at ChildProcess.onCpExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:337:16)
gyp ERR! stack     at ChildProcess.EventEmitter.emit (events.js:98:17)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (child_process.js:797:12)
gyp ERR! System Linux 3.13.0-32-generic
gyp ERR! command "node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /home/raquel/Windshaft-cartodb/node_modules/windshaft/node_modules/canvas
gyp ERR! node -v v0.10.26
gyp ERR! node-gyp -v v0.12.2
gyp ERR! not ok 
npm http GET https://registry.npmjs.org/wordwrap/-/wordwrap-0.0.3.tgz
npm http GET https://registry.npmjs.org/minimist/-/minimist-0.0.10.tgz
npm http 200 https://registry.npmjs.org/minimist/-/minimist-0.0.10.tgz
npm http 200 https://registry.npmjs.org/wordwrap/-/wordwrap-0.0.3.tgz
npm http GET https://github.com/CartoDB/carto/archive/master.tar.gz
npm ERR! error rolling back Error: ENOTEMPTY, rmdir '/home/raquel/Windshaft-cartodb/node_modules/windshaft/node_modules/carto/node_modules/mapnik-reference'
npm ERR! error rolling back  windshaft@0.51.0 { [Error: ENOTEMPTY, rmdir '/home/raquel/Windshaft-cartodb/node_modules/windshaft/node_modules/carto/node_modules/mapnik-reference']
npm ERR! error rolling back   errno: 53,
npm ERR! error rolling back   code: 'ENOTEMPTY',
npm ERR! error rolling back   path: '/home/raquel/Windshaft-cartodb/node_modules/windshaft/node_modules/carto/node_modules/mapnik-reference' }
npm ERR! canvas@1.2.7-cdb1 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the canvas@1.2.7-cdb1 install script.
npm ERR! This is most likely a problem with the canvas package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-gyp rebuild
npm ERR! You can get their info via:
npm ERR!     npm owner ls canvas
npm ERR! There is likely additional logging output above.

npm ERR! System Linux 3.13.0-32-generic
npm ERR! command "/usr/bin/node" "/usr/bin/npm" "install"
npm ERR! cwd /home/raquel/Windshaft-cartodb
npm ERR! node -v v0.10.26
npm ERR! npm -v 1.4.3

I can get rid of that error if I do sudo apt-get install libpango1.0-dev and re-install with npm install, but I'm not sure if this is just a hack and I've done something wrong earlier by not installing the correct npm version.

Jun 9, 2022 in Node-js by Vaani
• 7,060 points

1 answer to this question.

0 votes

Here's the complete list (between v0.10.0 - v0.10.40):

  • node v0.10.0 -> npm v1.2.14
  • node v0.10.1 -> npm v1.2.15
  • node v0.10.2 -> npm v1.2.15
  • node v0.10.3 -> npm v1.2.17
  • node v0.10.4 -> npm v1.2.18
  • node v0.10.5 -> npm v1.2.18
  • node v0.10.6 -> npm v1.2.18
  • node v0.10.7 -> npm v1.2.21
  • node v0.10.8 -> npm v1.2.23
  • node v0.10.9 -> npm v1.2.24
  • node v0.10.10 -> npm v1.2.25
  • node v0.10.11 -> npm v1.2.30
  • node v0.10.12 -> npm v1.2.32
  • node v0.10.13 -> npm v1.3.2
  • node v0.10.14 -> npm v1.3.5
  • node v0.10.15 -> npm v1.3.5
  • node v0.10.16 -> npm v1.3.8
  • node v0.10.17 -> npm v1.3.8
  • node v0.10.18 -> npm v1.3.8
  • node v0.10.19 -> npm v1.3.11
  • node v0.10.20 -> npm v1.3.11
  • node v0.10.21 -> npm v1.3.11
  • node v0.10.22 -> npm v1.3.14
  • node v0.10.23 -> npm v1.3.17
  • node v0.10.24 -> npm v1.3.21
  • node v0.10.25 -> npm v1.3.24
  • node v0.10.26 -> npm v1.4.3
  • node v0.10.27 -> npm v1.4.8
  • node v0.10.28 -> npm v1.4.9
  • node v0.10.29 -> npm v1.4.14
  • node v0.10.30 -> npm v1.4.21
  • node v0.10.31 -> npm v1.4.23
  • node v0.10.32 -> npm v1.4.28
  • node v0.10.33 -> npm v1.4.28
  • node v0.10.34 -> npm v1.4.28
  • node v0.10.35 -> npm v1.4.28
  • node v0.10.36 -> npm v1.4.28
  • node v0.10.37 -> npm v1.4.28
  • node v0.10.38 -> npm v1.4.28
  • node v0.10.39 -> npm v1.4.28
  • node v0.10.40 -> npm v1.4.28

However, I propose that you utilise n or nvwm. With either of them, you don't have to be concerned about the versions.

To know more about Node JS, It's recommended to join Node JS Course today.

answered Jun 9, 2022 by Neha
• 9,060 points

Related Questions In Node-js

0 votes
1 answer

How to install a previous exact version of a NPM package?

Hello @kartik, If you have to install an ...READ MORE

answered Jul 8, 2020 in Node-js by Niroj
• 82,880 points
0 votes
1 answer

How to find the version of an installed node.js/npm package?

Hello, npm view <package> version - returns the latest ...READ MORE

answered Nov 24, 2020 in Node-js by Niroj
• 82,880 points
0 votes
1 answer

Installing angularjs with NPM and NODEJS brings an error in ubuntu 16.04

Rename your angular folder to angular-test or ...READ MORE

answered May 30, 2022 in Node-js by Vaani
• 7,060 points
0 votes
0 answers

Sync contacts using Google Contacts API version 3.0 and NodeJS' Passport

I'm using passport and would like to ...READ MORE

Jun 21, 2022 in Node-js by Vaani
• 7,060 points
0 votes
1 answer

Truffle tests not running after truffle init

This was a bug. They've fixed it. ...READ MORE

answered Sep 11, 2018 in Blockchain by Christine
• 15,790 points
0 votes
1 answer

Hyperledger Sawtooth vs Quorum in concurrency and speed Ask

Summary: Both should provide similar reliability of ...READ MORE

answered Sep 26, 2018 in IoT (Internet of Things) by Upasana
• 8,620 points
0 votes
1 answer

sudo: npm: command not found

To answer your question, for me, the ...READ MORE

answered Feb 17, 2022 in Others by Aditya
• 7,680 points
0 votes
1 answer

Nodejs: question of type input with npm inquirer not working

The right code should be: const outPath = ...READ MORE

answered Jun 7, 2022 in Node-js by Neha
• 9,060 points
0 votes
1 answer

What is the role of Nodejs and Express in a MERN stack web application when GraphQL is also used?

Node.js is a JavaScript runtime environment, which ...READ MORE

answered May 27, 2022 in Node-js by Neha
• 9,060 points
webinar_success Thank you for registering Join Edureka Meetup community for 100+ Free Webinars each month JOIN MEETUP GROUP