Not able to expose port 80 on the host kubernetes ingress

0 votes

I’m trying to work ingress with kubernetes but it doesn’t work. I’m able to deploy everything successfully, but not able to expose port 80 on the host and hence I have no access.

I’m using this tutorial

Sep 11, 2018 in Kubernetes by lina
• 8,220 points

edited Sep 11, 2018 by lina 887 views

2 answers to this question.

0 votes
Are you using flannel by any chance?
answered Sep 11, 2018 by Kalgi
• 52,350 points
Yesss I'm using flannel
0 votes

I was facing the same error.

The nginix ingress controller uses hostPort to expose ports 80 and 443 directly from the host. However, even I'm using Flannel as an overlay network with CNI, and hostPort is unavailable when CNI is used.

I could use nodePort, but then I may as well just use a regular service anyway. I'll be using a standard load balancer in front of my ingress hosts that's not part of the Kubernetes system and it should work just fine.

answered Sep 11, 2018 by Kalgi
• 52,350 points

Related Questions In Kubernetes

0 votes
1 answer

Unable to deploy nginx ingress on kubernetes

The nginix ingress controller uses hostPort to ...READ MORE

answered Oct 1, 2018 in Kubernetes by Kalgi
• 52,350 points
311 views
0 votes
1 answer

Unable to open jenkins on the slave- Kubernetes

Execute these commands first and let me ...READ MORE

answered Dec 19, 2018 in Kubernetes by Charlie
313 views
+1 vote
1 answer
0 votes
3 answers

Error while joining cluster with node

Hi Kalgi after following above steps it ...READ MORE

answered Jan 17, 2019 in Others by anonymous
12,370 views
+4 votes
1 answer

Installing Web UI (Dashboard):kubernetes-dashboard on main Ubuntu 16.04.6 LTS (Xenial Xerus) server

Follow these steps: $ kubeadm reset $ kubeadm init ...READ MORE

answered Apr 12, 2019 in Kubernetes by Kalgi
• 52,350 points

reshown Apr 12, 2019 by Kalgi 3,996 views
0 votes
1 answer

Not able to access the kubernetes dashboard

Have you executed this proxy command? kubectl proxy Try ...READ MORE

answered Oct 8, 2018 in Kubernetes by Kalgi
• 52,350 points
707 views
0 votes
1 answer

Not able to access kubernetes api from a pod in azure

Follow these steps Add --bind-address=0.0.0.0 option to the line https://github.com/kubernetes/kubernetes/blob/v1.2.0/docs/getting-started-guides/coreos/azure/cloud_config_templates/kubernetes-cluster-main-nodes-template.yml#L218  Created ...READ MORE

answered Aug 30, 2018 in Kubernetes by Kalgi
• 52,350 points
465 views
webinar REGISTER FOR FREE WEBINAR X
Send OTP
REGISTER NOW
webinar_success Thank you for registering Join Edureka Meetup community for 100+ Free Webinars each month JOIN MEETUP GROUP