Not able to expose port 80 on the host, kubernetes ingress

0 votes

I’m trying to work ingress with kubernetes but it doesn’t work. I’m able to deploy everything successfully, but not able to expose port 80 on the host and hence I have no access.

I’m using this tutorial

Sep 11, 2018 in Kubernetes by lina
• 8,100 points

edited Sep 11, 2018 by lina 50 views

2 answers to this question.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
0 votes
Are you using flannel by any chance?
answered Sep 11, 2018 by Kalgi
• 36,220 points
Yesss I'm using flannel
0 votes

I was facing the same error.

The nginix ingress controller uses hostPort to expose ports 80 and 443 directly from the host. However, even I'm using Flannel as an overlay network with CNI, and hostPort is unavailable when CNI is used.

I could use nodePort, but then I may as well just use a regular service anyway. I'll be using a standard load balancer in front of my ingress hosts that's not part of the Kubernetes system and it should work just fine.

answered Sep 11, 2018 by Kalgi
• 36,220 points

Related Questions In Kubernetes

0 votes
1 answer

Unable to deploy nginx ingress on kubernetes

The nginix ingress controller uses hostPort to ...READ MORE

answered Oct 1, 2018 in Kubernetes by Kalgi
• 36,220 points
48 views
0 votes
1 answer

Unable to open jenkins on the slave- Kubernetes

Execute these commands first and let me ...READ MORE

answered Dec 18, 2018 in Kubernetes by Charlie
41 views
0 votes
1 answer
0 votes
3 answers

Error while joining cluster with node

Hi Kalgi after following above steps it ...READ MORE

answered Jan 17 in Others by anonymous
680 views
+3 votes
1 answer
0 votes
1 answer

Not able to access the kubernetes dashboard

Have you executed this proxy command? kubectl proxy Try ...READ MORE

answered Oct 8, 2018 in Kubernetes by Kalgi
• 36,220 points
35 views
0 votes
1 answer

Not able to access kubernetes api from a pod in azure

Follow these steps Add --bind-address=0.0.0.0 option to the line https://github.com/kubernetes/kubernetes/blob/v1.2.0/docs/getting-started-guides/coreos/azure/cloud_config_templates/kubernetes-cluster-main-nodes-template.yml#L218  Created ...READ MORE

answered Aug 30, 2018 in Kubernetes by Kalgi
• 36,220 points
32 views

© 2018 Brain4ce Education Solutions Pvt. Ltd. All rights Reserved.
"PMP®","PMI®", "PMI-ACP®" and "PMBOK®" are registered marks of the Project Management Institute, Inc. MongoDB®, Mongo and the leaf logo are the registered trademarks of MongoDB, Inc.