error failed to run Kubelet Running with swap on is not supported please disable swap or set --fail-swap-on flag to

0 votes

Hi Guys,

I have set all the requirements to configure Kubernetes Cluster. But when I am running the kubeadm init command it is showing me the below error.

error: failed to run Kubelet: Running with swap on is not supported, please disable swap! or set --fail-swap-on flag to
Sep 16, 2020 in Kubernetes by akhtar
• 38,170 points
751 views

1 answer to this question.

0 votes

Hi@akhtar,

To configure Kubernetes Cluster you need to disable your swap in your system. Kubernetes will not allow swap service. So before running the init command in your master node, make sure swap is disabled. Otherwise, you can use the below command to disable swap.

$ sudo swapoff -a
answered Sep 16, 2020 by MD
• 95,060 points

Related Questions In Kubernetes

0 votes
1 answer
+1 vote
1 answer
+1 vote
1 answer
0 votes
3 answers

Error while joining cluster with node

Hi Kalgi after following above steps it ...READ MORE

answered Jan 17, 2019 in Others by anonymous
9,879 views
+4 votes
1 answer

Installing Web UI (Dashboard):kubernetes-dashboard on main Ubuntu 16.04.6 LTS (Xenial Xerus) server

Follow these steps: $ kubeadm reset $ kubeadm init ...READ MORE

answered Apr 11, 2019 in Kubernetes by Kalgi
• 52,290 points

reshown Apr 12, 2019 by Kalgi 3,012 views
0 votes
1 answer