No match for argument ansible Error Unable to find a match

0 votes

Hi Guys,

I am trying to install ansible in my Linux system, but it is showing me the below error.

[root@localhost ~]# yum install ansible
Updating Subscription Management repositories.
Unable to read consumer identity
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Repository 'docker' is missing name in configuration, using id.
Repository 'App' is missing name in configuration, using id.
Repository 'Base' is missing name in configuration, using id.
Last metadata expiration check: 1 day, 0:45:10 ago on Sun 26 Jul 2020 10:55:34 PM IST.
No match for argument: ansible
Error: Unable to find a match

How can I solve this error?

Jul 27, 2020 in Ansible by akhtar
• 38,180 points
4,426 views

1 answer to this question.

0 votes

Hi@akhtar,

Ansible is not part of your RedHat DVD. It is a part of the python package. You need to install Ansible using the pip3 command as shown below.

[root@localhost ~]# pip3 install ansible
WARNING: Running pip install with root privileges is generally not a good idea. Try `pip3 install --user` instead.
Collecting ansible  Downloading https://files.pythonhosted.org/packages/e8/b2/c10b82573bb494d9e0764b5c75eb7be1e649082435280f2220976d1a3b33/ansible-2.9.11.tar.gz (14.2MB)
    100% |████████████████████████████████| 14.3MB 54kB/s
Collecting jinja2 (from ansible)  Downloading https://files.pythonhosted.org/packages/30/9e/f663a2aa66a09d838042ae1a2c5659828bb9b41ea3a6efa20a20fd92b121/Jinja2-2.11.2-py2.py3-none-any.whl (125kB)
    100% |████████████████████████████████| 133kB 121kB/s
Requirement already satisfied: PyYAML in /usr/lib64/python3.6/site-packages (from ansible)
Requirement already satisfied: cryptography in /usr/lib64/python3.6/site-packages (from ansible)
Collecting MarkupSafe>=0.23 (from jinja2->ansible)  Downloading https://files.pythonhosted.org/packages/b2/5f/23e0023be6bb885d00ffbefad2942bc51a620328ee910f64abe5a8d18dd1/MarkupSafe-1.1.1-cp36-cp36m-manylinux1_x86_64.whl
Requirement already satisfied: idna>=2.1 in /usr/lib/python3.6/site-packages (from cryptography->ansible)
Requirement already satisfied: asn1crypto>=0.21.0 in /usr/lib/python3.6/site-packages (from cryptography->ansible)
Requirement already satisfied: six>=1.4.1 in /usr/lib/python3.6/site-packages (from cryptography->ansible)
Requirement already satisfied: cffi!=1.11.3,>=1.7 in /usr/lib64/python3.6/site-packages (from cryptography->ansible)
Requirement already satisfied: pycparser in /usr/lib/python3.6/site-packages (from cffi!=1.11.3,>=1.7->cryptography->ansible)
Installing collected packages: MarkupSafe, jinja2, ansible
  Running setup.py install for ansible ... done
Successfully installed MarkupSafe-1.1.1 ansible-2.9.11 jinja2-2.11.2
answered Jul 27, 2020 by MD
• 95,240 points
Thanks. It worked for me as well.

Related Questions In Ansible

0 votes
1 answer
0 votes
1 answer

unable to build grails war on a vagrant machine using ansible

Try and run the command using shell ...READ MORE

answered Jul 2, 2018 in Ansible by ajs3033
• 7,280 points
287 views
+15 votes
2 answers

Git management technique when there are multiple customers and need multiple customization?

Consider this - In 'extended' Git-Flow, (Git-Multi-Flow, ...READ MORE

answered Mar 26, 2018 in DevOps & Agile by DragonLord999
• 8,450 points
1,194 views
+2 votes
1 answer
0 votes
1 answer

No match for argument: sshpass Error: Unable to find a match

Hi@akhtar, The sshpass software is not part of ...READ MORE

answered Jul 28, 2020 in Ansible by MD
• 95,240 points
1,477 views