Cannot find module 'fabric-network' - is my application installation done wrong?

0 votes

Hey community,

I'm trying to follow the tutorial https://hyperledger-fabric.readthedocs.io/en/latest/write_first_app.html

When I reach the step with installing the the application with npm install and then run ls I don't see the file package-lock.json. When I do the NPM install I have also tryed writing sudo npm install since I before have seen errors with missing rights to access.

In the next step where i run node enrollAdmin I get the error Error: Cannot find module 'fabric-network'. Is there missing anything in my installation?

I'm running Mac OS Mojave v10.14.5 - node v8.9.4 - npm v5.6.0.

Best regards Jeppe

May 19 in Blockchain by Jeppe
• 210 points
497 views

3 answers to this question.

0 votes
Best answer

First, install grpc and run it:

$ npm install grpc
$ grpc
answered May 20 by John

selected May 20 by Jeppe

I try to run from the fabcar directory these two commands. After npm install grpc I get:

grpc@1.20.3 install /Users/x/x/fabric-samples/fabcar/node_modules/grpc
> node-pre-gyp install --fallback-to-build --library=static_library

node-pre-gyp WARN Using needle for node-pre-gyp https download
[grpc] Success: "/Users/x/x/fabric-samples/fabcar/node_modules/grpc/src/node/extension_binary/node-v57-darwin-x64-unknown/grpc_node.node" is installed via remote

npm WARN fabcar@1.0.0 No description
npm WARN fabcar@1.0.0 No repository field.

+ grpc@1.20.3
updated 1 package in 5.588s

This seems to be alright, since it is only warnings and it says success to the installation.

But when I'm running grpc I get:

-bash: grpc: command not found

Should I change directory to the one above, where grpc is installed?

I did a little research and found that installing grpc should be enough. Can you run

node enrollAdmin 

and see if it works now?

0 votes

I had the same problem. The following solution worked for me:

$ npm update
$ npm install 
answered May 20 by Rishi

Thank you for your answer. But if I update npm - wouldn't I get version 9.x.x? In there requirement it says only version 8.9 is supported?

https://hyperledger-fabric.readthedocs.io/en/latest/prereqs.html

Does it matter in which folder I'm running the commands from?

Is it necessary to use sudo in front of the commands?

Best regards Jeppe

Hi @Jeppe.

In that case, you shouldn't update it. It does matter which folder you run the commands from. You should run thr command in the folder that contains the hyperledger project.
+1 vote

I managed to get it to enroll admin. I did two things and I'm not completely sure which of the commands were where the magic happend.

I did the following:

1)

$ npm install grpc

$ grpc

2)

$ npm install --python=python2.7

The second command was due to the fact that the prerequisites was python 2.7 - even though it was written for Ubuntu user only in https://hyperledger-fabric.readthedocs.io/en/latest/prereqs.html

I hope my post can help others in the future, like you two helped me!

answered May 20 by Jeppe
• 210 points

edited May 20 by Omkar
Glad to be of help! @Jeppe

Just wanted to clarify something. Did you try running it after installing grpc and before making changes to python? I want to analyze whether the solution was grpc or python.

Thanks!

@Rishi: As I wrote to John, it said -bash: grpc: command not found  when I tried to run grpc. So I assumed it didn't worked, but to be honest I didn't tried to run enroll admin immediately after before I ran npm install --python=python2.7.

Ok thanks! @Jeppe

Related Questions In Blockchain

0 votes
1 answer

My first Hyperledger fabric network is not working

Delete as admin the channel-artifacts folder, down ...READ MORE

answered Aug 10, 2018 in Blockchain by Johnathon
• 9,080 points
174 views
0 votes
4 answers

Hyperledger fabric: enrollAdmin.js Error: Cannot find module 'fabric-client'

Change your directory to fabric-samples/fabrcar. And run: npm ...READ MORE

answered Nov 21, 2018 in Blockchain by Omkar
• 67,660 points
1,286 views
0 votes
1 answer

How do I use hyperledger fabric blockchain to build my own application?

To use fabric I would recommend you ...READ MORE

answered May 16, 2018 in Blockchain by Johnathon
• 9,080 points
108 views
0 votes
1 answer
0 votes
1 answer

Invalid Batch or signature in Savtooth

This will solve your problem import org.apache.commons.codec.binary.Hex; Transaction txn ...READ MORE

answered Aug 1, 2018 in Blockchain by digger
• 26,550 points
86 views
+1 vote
1 answer
0 votes
1 answer

What is my chaincode ID in Hyperledger Fabric?

Hey. You have used chaincode id but ...READ MORE

answered Nov 21, 2018 in Blockchain by Omkar
• 67,660 points
367 views