Hyperledger Fabric: PEM encoded certificate is required.

0 votes

I am trying to access the remote peer from SDK using Hyperledger Fabric using following code

var peer = new Peer('Remote path', PemFile name)

it is giving me error that Error: PEM encoded certificate is required.

Nov 5, 2018 in Blockchain by digger
• 27,620 points
451 views

1 answer to this question.

0 votes

Hey, the syntax you are using is wrong. The right syntax is:

 var peer = newPeer('Remote Path', { pem: 'PEM file name' })
answered Nov 5, 2018 by Omkar
• 67,200 points

Related Questions In Blockchain

+1 vote
1 answer
+1 vote
1 answer

How hyperledger fabric is stored on a PC?

Firstly, your web application will interact with ...READ MORE

answered Apr 6, 2018 in Blockchain by Christine
• 15,790 points
58 views
+1 vote
1 answer

How immutability is achieved in hyperledger fabric?

Since it is a private blockchain platform, ...READ MORE

answered Apr 20, 2018 in Blockchain by Perry
• 17,010 points
251 views
0 votes
1 answer
0 votes
1 answer
0 votes
1 answer

Invalid Batch or signature in Savtooth

This will solve your problem import org.apache.commons.codec.binary.Hex; Transaction txn ...READ MORE

answered Aug 1, 2018 in Blockchain by digger
• 27,620 points
55 views
+1 vote
1 answer
+1 vote
4 answers
0 votes
1 answer

How is consensus achieved in a Hyperledger Fabric?

The transactions in the network is ordered ...READ MORE

answered Jun 29, 2018 in Blockchain by Omkar
• 67,200 points
362 views