Hyperledger Fabric: orderer launching fails with error "panic: Error reading configuration:Unsupported Config Type"

0 votes

I am trying to launch the orderer using the following commands:

export CHANNEL_NAME=my_channel 
export TIMEOUT=10000
export DELAY=3
export FABRIC_CFG_PATH=$PWD
export ORDERER_GENERAL_LOGLEVEL=debug
export ORDERER_GENERAL_LISTENADDRESS=0.0.0.0
export ORDERER_GENERAL_GENESISMETHOD=file
export ORDERER_GENERAL_GENESISFILE=./channel-artifacts/genesis.block
export ORDERER_GENERAL_LOCALMSPID=OrdererMSP
export ORDERER_GENERAL_LOCALMSPDIR=./crypto-config/ordererOrganizations/example.com/msp
export ORDERER_GENERAL_TLS_ENABLED=true
export ORDERER_GENERAL_TLS_PRIVATEKEY=./crypto-config/ordererOrganizations/example.com/orderers/orderer.example.com/tls/server.key
export ORDERER_GENERAL_TLS_CERTIFICATE=./crypto-config/ordererOrganizations/example.com/orderers/orderer.example.com/tls/server.crt
export ORDERER_GENERAL_TLS_ROOTCAS=[./crypto-config/ordererOrganizations/example.com/orderers/orderer.example.com/tls/ca.crt]

./orderer

This is the error I get:

2017-09-07 20:20:56.358 SGT [orderer/main] main -> INFO 001 Starting orderer:
 Version: development build
 Go version: go1.7
 OS/Arch: linux/amd64
2017-09-07 20:20:56.358 SGT [orderer/localconfig] Load -> CRIT 002 Error reading configuration: Unsupported Config Type ""
panic: Error reading configuration:Unsupported Config Type ""

goroutine 1 [running]:
panic(0xa488e0, 0xc4201ff1a0)
    /opt/go/go1.7.linux.amd64/src/runtime/panic.go:500 +0x1a1
github.com/hyperledger/fabric/vendor/github.com/op/go-logging.(*Logger).Panic(0xc42019f9b0, 0xc4201cf9e0, 0x2, 0x2)
    /w/workspace/fabric-binaries-x86_64/gopath/src/github.com/hyperledger/fabric/vendor/github.com/op/go-logging/logger.go:188 +0xd0
github.com/hyperledger/fabric/orderer/localconfig.Load(0xc42022c480)
    /w/workspace/fabric-binaries-x86_64/gopath/src/github.com/hyperledger/fabric/orderer/localconfig/config.go:231 +0x640
main.main()
    /w/workspace/fabric-binaries-x86_64/gopath/src/github.com/hyperledger/fabric/orderer/main.go:69 +0x309

Can someone tell me how to solve?

Oct 30, 2018 in Blockchain by digger
• 26,600 points
301 views

1 answer to this question.

0 votes

The error says there's some problem finding the configuration files. Have you set the right path to 

export FABRIC_CFG_PATH=$PWD

You should set this PATH to a folder name sampleconfig

answered Oct 30, 2018 by Omkar
• 68,480 points

Related Questions In Blockchain

+1 vote
4 answers

What role does Orderer peer serves in Hyperledger Fabric??

Shared communication channel to clients and peers ...READ MORE

answered Apr 11, 2018 in Blockchain by Johnathon
• 9,090 points
768 views
0 votes
1 answer
0 votes
1 answer

Not Able to register a user with Hyperledger-Fabric v1.1 preview

The error: "Certificate not found with AKI 'e729224e8b3f31784c8a93c5b8ef6f4c1c91d9e6e577c45c33163609fe40011' ...READ MORE

answered Jun 16, 2018 in Blockchain by charlie_brown
• 7,720 points
455 views
0 votes
1 answer
0 votes
1 answer

Invalid Batch or signature in Savtooth

This will solve your problem import org.apache.commons.codec.binary.Hex; Transaction txn ...READ MORE

answered Aug 1, 2018 in Blockchain by digger
• 26,600 points
96 views
+1 vote
1 answer
0 votes
1 answer
0 votes
1 answer