Error saying "client and server don't have same version (client : 1.19, server: 1.18)"

0 votes

Every time I run the command

$ docker compose up

It gives the following error

client and server don't have same version (client : 1.19, server: 1.18)

Which client and server is this error referring to and how do I get it fixed?

Jul 19, 2018 in DevOps Tools by Nilesh
• 6,880 points
459 views

1 answer to this question.

0 votes
As of docker-compose 1.4 you can now set the client API version, so you don't have to downgrade the client, or upgrade the server.

Set the environment variable COMPOSE_API_VERSION=auto to have it auto-detect the client version, or COMPOSE_API_VERSION=1.18 to set the exact version
answered Jul 19, 2018 by Kalgi
• 2,620 points

Related Questions In DevOps Tools

0 votes
1 answer
0 votes
1 answer
0 votes
1 answer
0 votes
1 answer

Deploy Docker Containers from Docker Cloud

To solve this problem, I followed advice ...READ MORE

answered Sep 3, 2018 in AWS by Priyaj
• 56,900 points
218 views
0 votes
1 answer
0 votes
1 answer

How to connect to Vault server

You need to configure the back end ...READ MORE

answered Jul 12, 2018 in DevOps Tools by Kalgi
• 2,620 points
499 views