CodePipeline Build failed, error asking for runtime version.

0 votes

I'm trying to run AWS CodePipeline but I ended up with the following error:

YAML_FILE_ERROR Message: This build image requires selecting at least one runtime version. 

How do I get rid of it?

Jun 27 in AWS by Vartika
240 views

1 answer to this question.

0 votes

If you use the aws/codebuild/standard:2.0 CodeBuild managed image, you must specify a runtime version in the runtime-versions section of the buildspec file. 

Like this:

phases:
  install:
    runtime-versions:
      java: openjdk8
      android: 28
      ruby: "$MY_RUBY_VAR"
answered Jun 27 by Haseeb

Related Questions In AWS

0 votes
1 answer

Error creating DB Instance: InvalidParameterCombination: Cannot find version 5.6.10a for aurora-mysql

I guess engine name 'aurora-mysql' refers to ...READ MORE

answered Sep 24, 2018 in AWS by Priyaj
• 56,520 points
349 views
0 votes
1 answer
+1 vote
2 answers