Error saying permission denied while running ansible playbook

0 votes

I'm following this blog to install OpenShift origin v3 on OpenStack using Ansible.  I got stuck with this error:

"Could not create fact file: %s, error: %s" % (filename, ex) main.OpenShiftFactsFileWriteError: Could not create fact file: /etc/ansible/facts.d/openshift.fact, error: [Errno 13] Permission denied: '/etc/ansible/facts.d'

Can somebody please help me.. 

Feb 8 in Ansible by Neha
325 views

1 answer to this question.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
0 votes

Hey @Neha, add the following line to your /etc/sudoers file:

centos All=(ALL) NOPASSWD:ALL

Let me know if it works.. Thank you :)

answered Feb 8 by Amy
Already tried that, didn't work :(

Add these two lines on ansible.config file:

sudo = true 
sudo_user = root
Ohh.. thanks worked like a charm.

Related Questions In Ansible

0 votes
1 answer

Permission denied when running ansible playbook through jenkins

Jenkins uses it's own user to execute ...READ MORE

answered Jun 25, 2018 in Ansible by DareDev
• 6,670 points
502 views
0 votes
1 answer

Remote host throwing error saying "Permission Denied" - Ansible

Hey @Patrick, Change the path of Ansible's remote_tmp ...READ MORE

answered Jan 16 in Ansible by Cerci
72 views
+13 votes
2 answers
0 votes
1 answer
0 votes
1 answer

Error saying script is already running - Ansible playbook error

Remove the previous processes before running this ...READ MORE

answered Feb 8 in Ansible by Dee
24 views

© 2018 Brain4ce Education Solutions Pvt. Ltd. All rights Reserved.
"PMP®","PMI®", "PMI-ACP®" and "PMBOK®" are registered marks of the Project Management Institute, Inc. MongoDB®, Mongo and the leaf logo are the registered trademarks of MongoDB, Inc.