"msg": "Depsolve Error occured: \n Problem: package docker-ce-3:19.03.12-3.el7.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed\n

0 votes

Hi Guys,

I am trying to install docker-engine using Ansible playbook. But it is showing me the below error.

FAILED! => {"changed": false, "failures": [], "msg": "Depsolve Error occured: \n Problem: package docker-ce-3:19.03.12-3.el7.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed\n  - cannot install the best candidate for the job\n  - package containerd.io-1.2.10-3.2.el7.x86_64 is excluded\n  - package containerd.io-1.2.13-3.1.el7.x86_64 is excluded\n  - package containerd.io-1.2.13-3.2.el7.x86_64 is excluded\n  - package containerd.io-1.2.2-3.3.el7.x86_64 is excluded\n  - package containerd.io-1.2.2-3.el7.x86_64 is excluded\n  - package containerd.io-1.2.4-3.1.el7.x86_64 is excluded\n  - package containerd.io-1.2.5-3.1.el7.x86_64 is excluded\n  - package containerd.io-1.2.6-3.3.el7.x86_64 is excluded", "rc": 1, "results": []}
Aug 4 in Ansible by akhtar
• 25,490 points
166 views

1 answer to this question.

0 votes

Hi@akhtar,

It seems you need to download some dependencies before you install docker-engine software. You can download the software from the below-given link.

$ yum -y install https://download.docker.com/linux/centos/7/x86_64/stable/Packages/containerd.io-1.2.6-3.3.el7.x86_64.rpm

I hope this will help.

answered Aug 4 by MD
• 57,800 points

Related Questions In Ansible

0 votes
1 answer
0 votes
1 answer
+2 votes
1 answer
+2 votes
1 answer

Deploy Docker Containers from Docker Cloud

To solve this problem, I followed advice ...READ MORE

answered Sep 3, 2018 in AWS by Priyaj
• 57,660 points
787 views
0 votes
1 answer