[error][savedobjects-service] This version of Kibana (v7.8.0) is incompatible with the following Elasticsearch nodes in your cluster: v7.7.1 @ 127.0.0.1:9200 (127.0.0.1)

0 votes

Hi Guys,

I am trying to start the Kibana server in my Linux system, but I am getting this below error.

  log   [09:55:47.553] [warning][config][encryptedSavedObjects][plugins] Generating a random key for xpack.encryptedSavedObjects.encryptionKey. To be able to decrypt encrypted saved objects attributes after restart, please set xpack.encryptedSavedObjects.encryptionKey in kibana.yml
  log   [09:55:47.981] [warning][config][plugins][security] Generating a random key for xpack.security.encryptionKey. To prevent sessions from being invalidated on restart, please set xpack.security.encryptionKey in kibana.yml
  log   [09:55:47.982] [warning][config][plugins][security] Session cookies will be transmitted over insecure connections. This is not recommended.
  log   [09:55:48.105] [warning][actions][actions][plugins] APIs are disabled due to the Encrypted Saved Objects plugin using an ephemeral encryption key. Please set xpack.encryptedSavedObjects.encryptionKey in kibana.yml.
  log   [09:55:48.136] [warning][alerting][alerting][plugins][plugins] APIs are disabled due to the Encrypted Saved Objects plugin using an ephemeral encryption key. Please set xpack.encryptedSavedObjects.encryptionKey in kibana.yml.
  log   [09:55:48.229] [info][monitoring][monitoring][plugins] config sourced from: production cluster
  log   [09:55:48.231] [warning][monitoring][monitoring][plugins] X-Pack Monitoring Cluster Alerts will not be available: undefined
  log   [09:55:49.122] [info][savedobjects-service] Waiting until all Elasticsearch nodes are compatible with Kibana before starting saved objects migrations...
  log   [09:55:49.127] [info][crossClusterReplication][plugins] Your basic license does not support crossClusterReplication. Please upgrade your license.
  log   [09:55:49.129] [info][plugins][watcher] Your basic license does not support watcher. Please upgrade your license.
  log   [09:55:49.131] [info][kibana-monitoring][monitoring][monitoring][plugins] Starting monitoring stats collection
  log   [09:55:49.207] [error][savedobjects-service] This version of Kibana (v7.8.0) is incompatible with the following Elasticsearch nodes in your cluster: v7.7.1 @ 127.0.0.1:9200 (127.0.0.1)
Jun 19 in ELK Stack by akhtar
• 33,120 points
1,937 views

1 answer to this question.

0 votes

Hi@akhtar,

The version of Kibana (v7.8.0) is incompatible with your current Elasticsearch. I have configured the ELK stack with a 7.7.1 version. All the tools are working very fine. So I suggest you use a 7.7.1 version for your all ELK tools.

answered Jun 19 by MD
• 78,020 points

Related Questions In ELK Stack

0 votes
2 answers

How to run Elasticsearch as root user in Linux machine?

Step 1: Pull images of elastic search ...READ MORE

answered Jun 19 in ELK Stack by Pawan
• 380 points
884 views
0 votes
1 answer

How to integrate Logstash with ElasticSearch?

Hi@akhtar, You can use elasticsearch plugin to integrate ...READ MORE

answered Jun 19 in ELK Stack by MD
• 78,020 points
106 views
0 votes
1 answer

How to change hostname in Kibana?

Hi@akhtar, You can change the hostname of your ...READ MORE

answered Jun 19 in ELK Stack by MD
• 78,020 points
456 views
0 votes
1 answer

How to install Kibana in Linux system?

Hi@akhtar, You can follow the below-given steps to ...READ MORE

answered Jun 19 in ELK Stack by MD
• 78,020 points
96 views
+15 votes
2 answers

Git management technique when there are multiple customers and need multiple customization?

Consider this - In 'extended' Git-Flow, (Git-Multi-Flow, ...READ MORE

answered Mar 26, 2018 in DevOps & Agile by DragonLord999
• 8,450 points
804 views
+2 votes
1 answer
0 votes
1 answer

How to install Elasticsearch tool in Linux System ?

Hi@akhtar, You can follow the below-given steps to ...READ MORE

answered Jun 19 in ELK Stack by MD
• 78,020 points
89 views