The connection to the server localhost:8080 was refused

+1 vote
$ kubectl get svc

The connection to the server localhost:8080 was refused - did you specify the right host or port?
Aug 8 in Kubernetes by Lakshminarayanan
54 views

Hey @Lakshiminarayanan, did you execute the following commands after kubeadm init?

sudo cp /etc/kubernetes/admin.conf $HOME/
sudo chown $(id -u):$(id -g) $HOME/admin.conf
export KUBECONFIG=$HOME/admin.conf
/etc/kubernetes/admin.conf file missing
Have you already created a Kubernetes cluster? You seem to have gone wrong somewhere while creating the cluster if your admin.conf file is missing.

What steps have you followed?
You don't really need minikube to create a kubernetes cluster and deploy an application.

No answer to this question. Be the first to respond.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.

Related Questions In Kubernetes

0 votes
2 answers

Not able to expose port 80 on the host, kubernetes ingress

I was facing the same error. The nginix ...READ MORE

answered Sep 11, 2018 in Kubernetes by Kalgi
• 39,170 points
66 views
0 votes
1 answer

css download not adding /grafana to the URL.

You need to change root_url grafana's server setting to /grafana/: root_url ...READ MORE

answered Sep 12, 2018 in Kubernetes by Kalgi
• 39,170 points
58 views
0 votes
1 answer
0 votes
3 answers

Error while joining cluster with node

Hi Kalgi after following above steps it ...READ MORE

answered Jan 17 in Others by anonymous
1,578 views
+3 votes
1 answer